Fix "npm ERR! Error: No compatible version found:" errors by upgrading

Blog

Fix "ERR! Error: No compatible version found: browser-sync-client@'^0.1.7'" errors with npm by upgrading your node version.

Barfs:

$ node --version 
v0.10.9

Works:

bash-3.2$ node --version 
v0.10.28
npm http 200 https://registry.npmjs.org/browser-sync-control-panel/0.0.5
npm http GET https://registry.npmjs.org/commander/-/commander-2.1.0.tgz
npm ERR! Error: No compatible version found: browser-sync-client@'^0.1.7'
npm ERR! Valid install targets:
npm ERR! ["0.0.2","0.0.3","0.0.4","0.0.5","0.1.0","0.1.1","0.1.2","0.1.3","0.1.4","0.1.5","0.1.6","0.1.7","0.1.8"]
npm ERR!     at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:709:10)
npm ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:631:10
npm ERR!     at saved (/usr/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7)
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this log at:

Also recommended:

$ npm cache clear
$ npm rebuild

Comments

Thanks for the information. The npm cache clear and rebuild helped me.